Community Project | Cardinal Menu System Instructions, Help, and Discussion

  • Stefan said in Community Project | Cardinal Menu System Instructions, Help, and Discussion:

    Hi, I downloaded your project files, but when I need to rebuild I get error: "CardinalMenu could not be compiled. Try rebuilding from source manually". I tried on every version of your project, on 3 different pc and no luck, please can you help me? I use Microsoft Visual Studio 2015 Enterprise

    Do you have this problem on all UE4 projects with source code? I've had this problem for many various reasons in the past. You can try this.

    Right click on CardinalMenu.uproject and select Generate Visual Studio project files. It should have created CardinalMenu.sln in the same directory.
    Open CardinalMenu.sln
    In Solution Explorer (typically on the right) open Games -> CardinalMenu
    Right click on CardinalMenu in Solution Explorer and click rebuild.
    A log should appear on the bottom and show you errors.
    Paste this log here and I'll look at it.

    Other Possible Solutions
    A common problem I get is Visual Studio logs my credentials out for some reason. I have to open Visual Studio and on the top right there's a drop down arrow and it says "An error has occurred and we can no longer retrieve user information for... " I then have to log in. This might be in Community Edition only though. I haven't used the enterprise version of VS 2015. Only older versions.

    Another problem is the C++ compile add ons might not be included with your install of VS2015. Is this the first project you've used for UE4? Usually this happens when someone first starts messing around with Unreal 4 or they are using a new computer. Here's the solution.
    "Visual Studio 2015 (VS2015) doesn't install C++ tooling support by default. When installing VS2015, choose Custom installation and then choose the C++ components that you'll need for your workflow. If you've already installed Visual Studio 2015, choose File > New > Project > C++ to install C++."

  • Hi, everyone! Thank you for the excellent work here! I'm learning a lot!

    I've integrated the Cardinal menu into my project and I'm having one issue with key bindings. My game has seven action inputs and two of them do not work after remapping for PC. Only three inputs work on an XBOX controller. The working XBOX actions are different than the working PC actions.

    I have the defaults setup, actions are in alphabetical order, and I see the Input's swap under project settings.

    Any ideas?

  • This post is deleted!

  • Here are where the controls are stored.

    Input.ini and in your project configs
    The DefaultActionBinds in ControlsSettingsDetails located at /Game/Cardinal/MainMenu/Blueprints/UI/SettingsPanels/ControlsSettingsDetails
    DefaultAxisBinds located in RAMA-AxisControls at /Game/Cardinal/MainMenu/Blueprints/UI/SettingsPanels/RAMA-AxisControls

    The order matters to the engine. It should be alphabetical. To my knowledge, nobody has come up with a better method without programming one or using a form of real time binds on every tick such as Mathew Wadstein's BindableKeys system. (Bypassing UE4's method basically)

  • Sorry I couldn't be much more help. I'm out of town for the US holiday weekend. I will be back on Monday and take a look at the input system and see if I find any issues. I need to make the new release for 4.17 as well. Hopefully the plugins have no problems with the new engine. That is why we wait a bit for new releases.

  • I'm going to make the instructions more reader friendly next week as well. The forum software's plugin for "spoilers" is no longer working. I was hiding the instructions with dynamic buttons that hide the different instructions settings to make it more readable.

  • A few of the plugins are not working for 4.17 yet. It will be a bit before the 4.17 version is released.

  • The menu system for Unreal Engine 4.17 has been released. It includes an in game return to game button and a debug print to screen fix.

  • when i test the project with not run steam , it cant find hostgame list , LAN not work. do you have this issue ?

  • have somebody test project with LAN ?

  • All of my previous test have worked. I will test it right now.

    Edit: Strange, it doesn't appear to be working on Ethernet to WiFi LANs on my network. (Could be related to how my network is set up) I'll check Ethernet to Ethernet. I'm looking into it. I've experienced some cases where certain types of network setups didn't show LAN games or took a long time for them to appear.

    I'm looking into Advanced Sessions Plugin and the BP nodes. I'll hopefully have fix tomorrow. Very little has changed in 4.15-4.17 versions.

    Edit 2: It works in editor. Looking into network related things.

    Edit 3: Standalone works as well. Hmm, looking into possible packaged version configuration file problems.

    Edit 4: Packaged LAN search and join works on the same PC when launching two instances. Going to try ethernet via switch LAN on two PCs.

    Edit 5: It works on LAN network via wired on a local switch. It did not work on WiFi via WiFi Access Point to a wired client. I don't know why. It must have something to do with how Epic designed the sessions broadcasting over the network. My guess is that there's a broadcast packet that's being blocked by my access point.

    Did you try LAN over wired networks? Or did you use WiFi?

  • The menu system for Unreal Engine 4.18 has been released.


Looks like your connection to Metahusk Community was lost, please wait while we try to reconnect.